Can't program location 0 in a mega1280?

5 posts / 0 new
Last post
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Computer is XP with SP3. AVRstudio 4.19. I have a jtagmkii and a clone jtag1. Using the jtagmkii, I can connect, read signature, read and write fuses, but when I write the hex file, the verify says "loc 0 was 0x3f, should be 0x0c". I have a theory that a slightly out of spec vcc might cause programming or verifying errors. I also have a laptop with win7 and AVRstudio5 and a jtag3 that I'm going to try tomorrow. I have a copy of AVRstudio5 on the XP machine, but it can't find the jtagmkii. I guess this is a known issue? I searched the AVRstudio4 forum for "location 0" but its hard to imagine that unlucky old Bob is the only dude in the world trying to program a mega1280 with a jtagmkii and AVRstudio4.19 on an XP-SP3 machine. Its lonely at the top. Somebody else seen a problem like this?

Imagecraft compiler user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I've had that msg. ( probably not the same numbers EXCEPT for the loc. 0 ) using different MCUs, from large tiny-series up to Xmegas using my MKII ISP and Dragon. 've found that it's a problem that... :roll: goes away after awhile . I've tried unplugging the programmer cable, closing Studio and re-opening again . Sometimes it works and sometimes not . Sometimes a little time is all it takes to make it go away . I never could find "THE" solution to fix it when it happened . :cry:

1) Studio 4.18 build 716 (SP3)
2) WinAvr 20100110
3) PN, all on Doze XP... For Now
A) Avr Dragon ver. 1
B) Avr MKII ISP, 2009 model
C) MKII JTAGICE ver. 1

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thank God. I thought I was alone in the Universe. Gee, you think I should open a Software Problem Report about this? Naaah... they must know about it.

Imagecraft compiler user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have used the 1280 with a AVRISP MK1, Dragon and JTAG Mk2 without problems but I'm still using Studio 4.18.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I had 4.18 on my machine at work, but I figured 4.19 would have the newer AVRs, and be backward compatible. Maybe some of the Atmel VPs that are policing the forum here could tell one of the engineers to definitively state whether 4.19 has a known issue with programming a mega1280 using a jtagmkii? If the workaround is dl 4.18, just say so. All this darn messing around with different programmers and avrstudio versions is a Big Waste O My Time. Since it is rumored that actual Atmel employees might read the messages here, I hereby submit this suggestion, from a working engineer and Atmel stockholder, that uses the stuff Every Day: How about making one darn version of the programming sw that will work with a jtagmkii that will program all the darn AVRs?

The laptop with win7, studio5 and the jtag3 works like a champ.

Imagecraft compiler user