avr-objcopy ELF No such file

4 posts / 0 new
Last post
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,
I'm using AVRStudio 4.19 and I cannot compile my projects, new or old ones, it doesn't matter. I get the same error:

avr-objcopy: 'test.elf': No such file

In my previous setup if I remember correctly AvrStudio worked "out of the box" no configuration needed.

here is a screenshot of Configuration Options menu:

What can be done to solve the issue?
Thanks

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If it's not generating the ELF it's because of a previous compile/link error so look at the "Build" tab for evidence.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

This happens even with older projects that compiled with no problems. Here is all the output:

Build started 1.10.2011 at 11:21:22
mmcu=atmega8 -Wall -gdwarf-2 -Os -std=gnu99 -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT main.o -MF dep/main.o.d  -c  ../main.c
/usr/bin/sh: -Wall: command not found
make: [main.o] Error 127 (ignored)
mmcu=atmega8 -Wl,-Map=test_sensors.map main.o     -o test_sensors.elf
/usr/bin/sh: -Wl,-Map=test_sensors.map: command not found
make: [test_sensors.elf] Error 127 (ignored)
avr-objcopy -O ihex -R .eeprom -R .fuse -R .lock -R .signature  test_sensors.elf test_sensors.hex
avr-objcopy: 'test_sensors.elf': No such file
make: *** [test_sensors.hex] Error 1
Build failed with 1 errors and 0 warnings...
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Problem solved by installing AVR Toolchain 3.3.0. I thought this package was included in the AVRStudio Setup.