no jtag devices found, fixed

Go To Last Post
16 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

"No JTAG devices found" is the message I got the last several times I tried to debug with an Atmel ICE through AS7 on Windows 10.

I've not made any hardware changes since the last time it worked.

I reseated all the cables.  I used to do tech support, I know the drill.

Also, the device manager claims it's working properly.

The device manager also says that VID/PID 03EB:2141 need further installation.

From a long edge in, three LEDs are steady green, steady orange and off.

When I try to use it, the third LED blinks and eventually goes out.

AS7 shows the right serial number for the device,

but when I try to read the target signature, it claims "No JTAG devices found."

On the other hand, it claims to be able to read the target device voltage just fine.

 

How do I get it working again?

International Theophysical Year seems to have been forgotten..
Anyone remember the song Jukebox Band?

Last Edited: Fri. Dec 8, 2017 - 08:21 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

skeeve wrote:
... through AS7 ...
Pre or post 7.0.1416?

Reason: 7.0.1416 replaced Jungo with WinUSB

Atmel Studio

Driver and USB Issues

http://www.microchip.com/webdoc/GUID-ECD8A826-B1DA-44FC-BE0B-5A53418A47BD/index.html?GUID-033A42FD-C88B-4874-AC33-7807B5F9C91F

skeeve wrote:
... on Windows 10.
A common Windows 10 issue is a driver update will make devices non-functional.

Driver updates can be disabled in Windows 10 though that procedure has several steps.

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

gchapman wrote:
skeeve wrote:
... through AS7 ...
Pre or post 7.0.1416?

Reason: 7.0.1416 replaced Jungo with WinUSB

Post: 7.0.1417
Quote:

Atmel Studio

Driver and USB Issues

http://www.microchip.com/webdoc/GUID-ECD8A826-B1DA-44FC-BE0B-5A53418A47BD/index.html?GUID-033A42FD-C88B-4874-AC33-7807B5F9C91F

skeeve wrote:
... on Windows 10.
A common Windows 10 issue is a driver update will make devices non-functional.

Driver updates can be disabled in Windows 10 though that procedure has several steps.

No kidding.

First I have to figure how to figure out how to roll back the current one.

International Theophysical Year seems to have been forgotten..
Anyone remember the song Jukebox Band?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

No joy.

The latest update of *anything* I can find is 11/16 10/16 .

The problem is more recent than that.

 

I'm reluctant to try the uninstall/reinstall method,

because I'm not at all certain I'll be able to do the second part.

It seems to me, that the icon would go away and I

would not know where to search to install it again.

 

When I click on repair, W10 tells me that it requires a resource not available.

Clicking on change, W10 seems to go through some motions before

quietly doing nothing.

 

How do I find joy (not Joy, that is in my kitchen).

 

Edit: corrected date

International Theophysical Year seems to have been forgotten..
Anyone remember the song Jukebox Band?

Last Edited: Thu. Dec 7, 2017 - 04:41 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

skeeve wrote:
The latest update of *anything* I can find is 10/16 .
Windows 10 limits the amount of stored previous builds.

Other options are restore points and backups.

AskWoody

How to roll back a bad driver update

Posted on December 30th, 2016 at 08:09

https://www.askwoody.com/2016/how-to-roll-back-a-bad-driver-update/

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

gchapman wrote:

skeeve wrote:
The latest update of *anything* I can find is 10/16 .
Windows 10 limits the amount of stored previous builds.

Other options are restore points and backups.

11/16 is older than my current.

At the moment, my system is in a state thaat I would not want to restore to.

Quote:

AskWoody

How to roll back a bad driver update

Posted on December 30th, 2016 at 08:09

https://www.askwoody.com/2016/how-to-roll-back-a-bad-driver-update/

Found it, but the updates listed do not have rollback as an option,

possibly because they are all more than ten days old.

 

The only vaguely relevant thing I can find that offers rollback

is the ELAN HID class filter driver.

It appears never to have been updated and its install date

is before I bought the computer new.

 

I really need to fix this.

It's a show-stopper.

International Theophysical Year seems to have been forgotten..
Anyone remember the song Jukebox Band?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

skeeve wrote:
Found it ...
Is "it" WinUSB?

If yes, WinUSB is mentioned in Zadig.

[Zadig icon]

Zadig - USB driver installation made easy

http://zadig.akeo.ie/

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

gchapman wrote:
skeeve wrote:
Found it ...
Is "it" WinUSB?
No.  It is the AskAndy rollback stuff.
Quote:

If yes, WinUSB is mentioned in Zadig.

The only mention I found of WinUSB was under Atmel-ICE data data gateway: device started (WinUSB).

Is WinUSB's absence the likely problem?

International Theophysical Year seems to have been forgotten..
Anyone remember the song Jukebox Band?

Last Edited: Thu. Dec 7, 2017 - 05:38 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

skeeve wrote:
Is WinUSB's absence the likely problem?
Very likely WinUSB is present.

Attention was drawn to your OP :

Also, the device manager claims it's working properly.

The device manager also says that VID/PID 03EB:2141 need further installation.

After the following then I'm at a loss :

(as-installer-7.0.1645-readme.pdf)

(page 15)

2.4 Driver and USB Issues

2.4.1  How do I get my Tool to be recognized by Atmel Studio?
This should happen automatically, but sometimes the Windows driver does not recognize the tool correctly. To correct this, you have to check that the tool is listed under the Atmel node in the device manager in Windows. If your tool is not listed, try to find it under Unknown devices. If it is located there, try to reinstall the driver by double clicking the tool, click the Driver tab and choose Update Driver. Let Windows search for the driver. The driver should be reinstalled and the tool should be displayed under Atmel. Now, the tool should be usable from Atmel Studio.

 

Edit: typo

 

"Dare to be naïve." - Buckminster Fuller

Last Edited: Thu. Dec 7, 2017 - 07:00 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Again, how many times do I have to repeat myself, Atmel-ICE uses HID for the debugger access. So there are no drivers required for debugging. DGI uses winusb for its transport, which is tied to the Data Visualiser.
.
We moved.the older bulk tools from jungo to winusb some time back (but this only applies to the MK2, stk600 and jtagice3 with firmware version 1 or 2.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I'm not using the Atmel-ICE just for debugging.

I'm also using it to install programs.

 

I tried to update the driver labelled Atmel-ICE data gateway.

W10 says it's already up to date.

International Theophysical Year seems to have been forgotten..
Anyone remember the song Jukebox Band?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

skeeve wrote:
...

I reseated all the cables.

...

but when I try to read the target signature, it claims "No JTAG devices found."

On the other hand, it claims to be able to read the target device voltage just fine.

...

IIRC the 50mil pitch target cable can become intermittent.

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

gchapman wrote:
skeeve wrote:
...

I reseated all the cables.

...

but when I try to read the target signature, it claims "No JTAG devices found."

On the other hand, it claims to be able to read the target device voltage just fine.

...

IIRC the 50mil pitch target cable can become intermittent.
According to a multimeter and some wire-wrap wire,

all ten connections are there.

Also, the ribbon cable connects to the AVR, not W10.

Would a broken AVR connection cause AS7 to not find the ICE?

International Theophysical Year seems to have been forgotten..
Anyone remember the song Jukebox Band?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

skeeve wrote:
Would a broken AVR connection cause AS7 to not find the ICE?
No

An alternate to the ribbon cable is the squid cable in a full kit Atmel-ICE.

I have no more ideas.

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

I borrowed another Atmel ICE, one with a different serial number.

AS7 noticed.

It worked.

After replacing it with the original,

the original worked also.

International Theophysical Year seems to have been forgotten..
Anyone remember the song Jukebox Band?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

That's a relief!

Want to buy a new Atmel-ICE (full kit)?

http://www.avrfreaks.net/forum/microchip-dev-tools-end-year-2017-sale

 

"Dare to be naïve." - Buckminster Fuller