ATMEGA1284P

Go To Last Post
83 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello Everyone;

                       I am new to ATMEGA1284P. I have decided to do one project with this microcontroller, but when I am uploading my program to it with USBtiny using eclipse software it is giving below message.

 

Error Message

This topic has a solution.
Last Edited: Tue. Nov 7, 2017 - 08:47 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I think 1e 97 06 is device signature for ATmega1284, not ATmega1284P. Are you sure your microcontroller is ATmega1284P, not ATmega1284?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

That seemed sort of strange. I was speculating that your AVRDUDE config file to might have the wrong signature set but the data sheet for the ATmega1284p clearly states that the signature bytes should be 0x1E 0x97 0x05.

 

So, I had a look in the config file to see if there was any signature 0x1e 0x97 0x06, and it's the ATmega1284 (with no "p"!). Double-checking against the ATmega1284 (again, no "p") confirms this.

 

Did you select the correct part number in your project?

 

EDIT: Beaten to it by Marek while double-checking the data shets and AVRDUDE configs...

"He used to carry his guitar in a gunny sack, or sit beneath the tree by the railroad track. Oh the engineers would see him sitting in the shade, Strumming with the rhythm that the drivers made. People passing by, they would stop and say, "Oh, my, what that little country boy could play!" [Chuck Berry]

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

Last Edited: Tue. Oct 24, 2017 - 12:00 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello;

        Thanks for reply my device has the part number printed on it:-- ATMEGA 1284 PU 1708. 

 

Also I am not able to get ATMEGA1284 (Not "P") in my avr dude hardware choose list.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The "PU" in "ATMEGA 1284 PU" is not to be confused with the "P" in "Atmega1284p". What you have is an ATmega1284, without the 'p'.

 

(The "PU" on your chip is about the actual packaging it is in.)

 

Any recent AVRDUDE should recognize "ATmega1284" (without the "p"). If your Eclipse plugin does not show it in a pick-list then the problem is likely with that plugin (i.e. not with AVRDUDE per se).

 

Can you provide a web-link to the Eclipse plugin?

"He used to carry his guitar in a gunny sack, or sit beneath the tree by the railroad track. Oh the engineers would see him sitting in the shade, Strumming with the rhythm that the drivers made. People passing by, they would stop and say, "Oh, my, what that little country boy could play!" [Chuck Berry]

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

Last Edited: Wed. Oct 25, 2017 - 05:05 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have install WinAVR-20100110 with my eclipse. Sorry I don't have the link. 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I found this think on internet. Is it helpful?? How I can use it please guide me.

 

 

 

https://gist.github.com/mattwilliamson/2853107

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Post a picture of the chip so that we know what you have.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Here is the picture. (Edited image to a smaller size - JS)

 

 

Last Edited: Wed. Oct 25, 2017 - 07:31 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

So this is Atmega1284, not Atmega1284P. The correct signature is 1e 97 06.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am not able to get atmega1284 in winavr (avr dude) hardware list in eclipse. So what I can do for this issue?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Install Arduino - it will deliver a much more up to date copy of avrdude. The one in WinAVR is 8 years old!

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have already written my code in C, and it is working fine in simulation. So, for me it is not possible to write hole code again.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Who suggested writing it all again?

 

I said "install Arduino" because in the 5,000+ files it puts on your hard drive that includes copies of fairly recent Windows builds of avrdud.exe, avrdude.conf etc.

 

Lift the 2 or 3 files that make the up to date copy of avrdude and store them somewhere safe then delete the other 4,998 files you don't actually need.

 

I know it's a bit of a sledgehammer to crack a nut approach but it will deliver to you a known working avrdude that is also being used by literally millions of other people.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What we are told: ATmega1284 does not show up in "the Eclipse plugin".

What we don't know: Is this a deficiency in "the Eclipse plugin" or does the OPs AVRDUDE miss ATmega1284? The latter seems strange since the ATmega1284p is supported (and the "p"s are the newer devices, right?)</