Reading the external crystal.

Go To Last Post
59 posts / 0 new

Pages

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

awneil wrote:
Isn't the transceiver crystal mandatory for radio operation anyhow?

To answer my own question:

 

Yes, the transceiver crystal is mandatory for radio operation - BUT selecting a different source for the CPU means that the CPU can continue to run while the radio is asleep

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

pika wrote:
From the datasheet this is the one thing I have found out.

So look also at Table 11-10 for the start-up time settings ...

This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

pika: What you have to do is hook up a 16MHz crystal (Xtal, 2 pins) with capacitors (2x, 10-20picofarad) to the XTAL pins (doesn't actually matter which, but see the schematic in post #20) and then set the rest of the AVR to run off the transceiver crystal.  Set the CLKSEL fuses to Transceiver Oscillator, longest possible startup time.

 

Try that.  If it doesn't work, get back to us, and we'll blizzard you once more with irrelevant trivia.  cheeky

 

S.

 

PS - The original 8pF caps you had are probably too small.  S.

PPS - No, you can't do RF with the AVRs internal RC. - Edit:  Ref. post above, as I did without proper credit. S.

 

Last Edited: Mon. Oct 2, 2017 - 03:44 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Okay. Now I have a clear picture. Thanks all of you. Its clear on my mind :) Thanks all for your time

 

Last Edited: Mon. Oct 2, 2017 - 03:46 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Scroungre wrote:
PPS - No, you can't do RF with the AVRs internal RC. S.

See #52.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello all,

 

I seslcted the option : Transceiver Oscillator;Start-up time : 16K CK +65ms. The program is flashed without any errors (using Start without degugging option). Then I tried the Start debugging option,but that leads to an error like the picture below. When I tried the internal RC it works fine. What does this mean ?

 

                                    

Last Edited: Wed. Oct 4, 2017 - 03:38 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello all,

 

This problem is solved. The launch failed happened because the external crystal was not working. Thank you all for your support.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

pika wrote:
This problem is solved

Thanks for the feedback.

 

Now, please mark the solution: http://www.avrfreaks.net/comment...

Pages