Is ATMEL ICE capable to program and debug ATtiny817

Go To Last Post
8 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,

 

Is ATMELICE is capable of a program and debug to ATtiny817? I am using ATMEL Studio 6, there I have connected Atmel ICE and seen the supported device but I couldn't able to find ATtiny817 in that list. Please give me the solution.

 

Thank you in advance. 

 

Regards,

 

Dinesh Jinjala

This topic has a solution.

Dinesh Jinjala

Last Edited: Tue. Aug 29, 2017 - 04:31 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

If you do not want to move to the latest development environment, do not try to use the latest chip.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Dear sir,

 

If I buy new Atmel ICE and install new Atmel Studio 7, then can I program with this new equipment? 

 

http://www.atmel.com/Images/Atme...

In this pdf, at page number 18, they have mentioned: "Connecting to a UPDI Target" in section 3.5.

 

Please solve my doubts. Actually, I need a small chip that has USART, SPI, TWI(Master and slave both) and should have inbuilt EEPROM in that IC with some extra GPIO. That's why I have chosen ATtiny817. And that IC must have a low price.

 

Thank you.

 

Regards,

 

Dinesh

 

Dinesh Jinjala

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I can choose the device in the project.
I can select Atmel ICE in the debugger

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Are you using atmel studio 7? which version you are using?

 

Dinesh Jinjala

This reply has been marked as the solution. 
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Dineshro wrote:
Is ATMELICE is capable of a program and debug to ATtiny817? I am using ATMEL Studio 6, there I have connected Atmel ICE and seen the supported device but I couldn't able to find ATtiny817 in that list. Please give me the solution.

 

I am using Studio 6_2 and AS7.  The Tiny817 does not appear in Studio 6_2 on my machine.  It DOES appear in AS7, so you will have to use AS7 in order to work with the part.  The Atmel ICE WILL program and debug the 817 using AS7.

 

 

 

kabasan wrote:
you do not want to move to the latest development environment, do not try to use the latest chip.

Hmmmm, in this case you are correct in that the 817 is only supported in AS7, but you could have been a little more cordial in your response eh?

 

Jim

If you want a career with a known path - become an undertaker. Dead people don't sue! - Kartman

Please Read: Code-of-Conduct

Atmel Studio6.2/AS7, DipTrace, Quartus, MPLAB user

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thank you, sir, for your response. It is very helpful to me.

Dinesh Jinjala

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

You are welcome!

 

JIm

If you want a career with a known path - become an undertaker. Dead people don't sue! - Kartman

Please Read: Code-of-Conduct

Atmel Studio6.2/AS7, DipTrace, Quartus, MPLAB user