USBASP and ATxmega128A1

Go To Last Post
5 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello

 

I'm trying to program an ATXmega128A1 using an USBASP V2.0, on PDI mode.   

I have read several tutorials but I  still can´t find a way to program it. 

Has anyone managed to successfully program it using this programmer?

 

Thank you

 

G_deSloZ - FPGA and electronics in general

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

First question: Does the firmware in the USBAsp you are using have PDI support?

 

IOW where did you get this USBAsp?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have never heard of USBASP with PDI either.

 

On the other hand,   if you select 3.3V operation and find and install some PDI firmware,  it should be possible.

 

Most Chinese USBASP have either a jumper-link or solder-bridge for 3.3V operation.

The original German hardware design does not support 3.3V.

 

David.

Last Edited: Mon. Jun 5, 2017 - 01:22 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

 

HI

 

"Does the firmware in the USBAsp you are using have PDI support?"

 

I think so. I got in this website https://ketturi.kapsi.fi/2013/05...

 

"IOW where did you get this USBAsp"

 

In the local market. I think is a china clone, because it was giving this error message "Error Setting ISP Clock". I applied a new firmware then it was solved.

 

Thanks

G_deSloZ - FPGA and electronics in general

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

When googling I found this...

 

http://szulat.blogspot.com/2012/...

 

That actually looks like "clever stuff" - to maintain the PDI clock while V-USB operates the comms link.

 

But it does seem to suggest it may be "do-able". However this does involve change of the USBAsp firmware and to achieve that you are going to probably need another ISp programmer  - probably a second USBAsp or maybe an Arduino if you have one.

 

EDIT:

I think so. I got in this website https://ketturi.kapsi.fi/2013/05...

And the "patches" link on that page then link back to that site I found. So it seems all roads lead to Rome!

 

However I doubt the default firmware in the device you have will include this modification. So are you saying you already used a 2nd ISP to reprogram the firmware in this USBAsp with the patched one that is supposed to support Xmega/PDI ?

Last Edited: Mon. Jun 5, 2017 - 01:28 PM