Atmel Studio 7.0.1416/7.0.1417

Go To Last Post
86 posts / 0 new

Pages

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

meolsen wrote:

Over-active antivirus?

 

Good point, unfortunately not. During my problem analysis I disabled/closed all unnecessary windows processes. The Task-Manager doesn't give me helpful hints.

 

Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sorry to be a pain, but where has Percepio Trace gone?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We've had to remove it since our redistribution license expired.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does it mean that it is removed from the Extensions as well? Can I revert the installation to a previous version to have it? Or will it disappear forever from the Extensions section? Is there a way to install it separately? Or will there be a similar feature installed?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We have removed it from the studio installation due to the license. However, if Percepio wants to make it available in the gallery is up to them. I don't know if they want to do that (I haven't had the chance to talk to them about this yet). 

 

I'm sure that if you ask them you'll at least get an answer wink

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Are you aware that the Atmel Studio Webpage still shows 1188 as the latest. Just downloaded the 1188 full installer and the first question was: "There is a newer version ..." ... sigh. Also the release notes are for 1188. The ones you posted here are newer.

 

@meolsen: You're doing a great job, thanks :-)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes, we know...

Note that when you download 1188, you don't have to check the "download newest" (if that was the question).

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am not privy to the contractual agreements between Atmel and Percepio. My understanding based on your statements is that Percepio Trace was removed from the Gallery by Atmel because of the agreement's expiry, but Percepio might not know about it yet?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

the trace plugin was never on the gallery....

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Oh, so it was part of the install? so the previous versions of Atmel would still have it?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Jupp :) 

 

(there's also ways of moving it between versions, but I think I'm passing my usual grey-zone of operation if I divulge too much smiley )

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

kawosch wrote:

Hi,

 

I'm running the 1417 under Windows 7. Installation worked, it compiles, but my GUI stucks about every 5 seconds for about 1-2 seconds. This is very annoying, a continuous workflow is nearly impossible (the complete Atmel Studio is affected). Did anyone else encountered this problem so far? The last Atmel Studio (1188 for me) worked fine.

 

Regards

 

After a complete reinstallation of Atmel Studio .1417 (by as-installer-7.0.1417-web.exe) everything works fine, last time I updated from .1188. I know that Atmel Studio is based on VS 2015, but my web search showed me, that some VS 2017 users have exactly the same problem. (link1 link2)

 

Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Where there's a will there's a way. I had the will, so I found the way.

 

Nonetheless, the release notes for the latest version should specify the disappearance of Percepio Trace.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just upgraded to the new version of Studio 7 7.0.1417. I'm using Windows 10. Now I can not see any of my programming tools.

The Device Programming screen shows: "There are no Available tools"

I also get an error saying "The back end process exited with code -1073740791"

What is going on?. Should I try to go back to my previous version. I'm using Windows 10.

Arturo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Is the new version still unofficial? I cannot find it on http://www.atmel.com/tools/atmel..., there is 7.0.1188. I can't find release notes for 7.0.1417 as well.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

That's right. However, when I tried to install 7.0.0.188 it says there is a later version and asks if you would like to install the newest version. I clicked yes and I got 7.0.1417.

Arturo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

7.0.1417 is official, it's just that updating the web site is a task that (obviously) takes some time. Not everything is running smooth after the merger. 

 

@acab, try to delete the content in Atmel\Studio\7.0\atbackend\codeCache\ and start Studio again. If not even the simulator is showing in the tools list there is nothing wrong with your tools, it's the backend that is having issues.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for your response. Unfortunately I got impatient and I decided to go back and install the old version I had which was working mostly. But It would crash with an error of "AVR8 Device Support". Therefore, I tried to re-install 7.0.1417 but I got the same error.
When I checked the Atmel site I noticed that the latest version recommended is 7.0.1188. So I donwloaded it and tried to install with the same result plus more errors listed. It also shows some links on how to troubleshoot. However when I click them I get sent to a web page that is not working.

I submitted a support case to Microchip but no answer yet.

I noticed Atmel studio still shows up as an installed. I tried to uninstall but that only restarts the installation and I get the same error again:


So to summarize my problem is that I don't have Atmel Studio anymore and any attempt to install it fail.

How can I get Atmel Studio installed again?

Arturo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

FYI!

It seems my problem was a corrupted registry. Tried to Fix it with Microsoft Fix-It but didn't work. Finally I used Revo Uninstaller and that worked. Great program!.

I have installed version 7.0.1188. I still have to properly fix everything but I'm hopeful.

Thanks everybody for listening to my sorrow.

Arturo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

acab wrote:
When I checked the Atmel site I noticed that the latest version recommended is 7.0.1188.
Recently updated :

http://www.microchip.com/development-tools/atmel-studio-7

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yep... website says 1417.

Ross McKenzie ValuSoft Melbourne Australia

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What's the "MPLAB" component installed when this version is installed?

 

Should I be worried we will eventually be forced to use that inferior IDE?

Last Edited: Tue. Apr 4, 2017 - 04:15 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

meolsen wrote:

We are working on updating the website. Getting there soon wink

 

Seriously? More than a month later and its still not updated!!!  How hard is it to update a link?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

My "soon" and yours are probably different. Why shouldn't theirs also be different. cheeky

Ross McKenzie ValuSoft Melbourne Australia

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

What are you talking about... It's on the site...

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Morten he is talking about the Atmel site link where people would normally go for Atmel stuff, it is still 1188

 

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

But, Atmel didn't make 7.0.1417... :-)

(I'll ask the web guys to link over to the Microchip site...)

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

Last Edited: Fri. Apr 21, 2017 - 09:32 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Oh dear, things are starting to get "very interesting but stupid"...you may be to young to remember Laugh In.wink

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,

I'm using win10 creators update (attached file), Atmel studio 7 build 1417, Atmega324P MCU and JTAGICE3/Atmel ICE. I can use JTAGICE3 or Atmel ICE to flash the code to board successfully. But can not debugging due to "Debugger command Prog Mode Leave failed" error, then the FUSES were reset (JTAGEN changed from checked to unchecked).

Do you have any idea to resolve this issue? Thank you.

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,

I tried to update to 7.0.1417 on Win 7 but it doesn't work. AS installer says that I have to update Windows KB2999226 (essential) and KB2670838 and KB2978092 (optional), but all are installed!

I tried to deinstall the 3 updates and reinstall using Windows Update - no success. AS installer doesn't finish the installation because of the missing updates.

What's going wrong and how can I install 1417?

Hans

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It’s always looking for IronPython v2.7.0.4

 

I had the latest IronPython installed 2.7.5, that didn’t work.

I reinstalled v2.7.4 and that didn’t work.

I can find a specific version 2.7.0.4

 

Thanks

Joe

 

 

 

If I try to create an Arduino project I get

 

If I click New Example Project I immediately get this

Joe

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

i installed AS 7.0.1417 on a Windows 10 64bit OS.

I have a AVR ISP MK2 Programmer.

 

In AS the Tools list stay empty, no Programmer, no Simulator.

Target is a ATtiny2313A.

 

The USB Device seems ok, and the programmer work with AVRDUDE.

 

Any Ideas?

 

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

lordraven wrote:

 

I have a AVR ISP MK2 Programmer.

..

In AS the Tools list stay empty, no Programmer, no Simulator.

Target is a ATtiny2313A.

..

Any Ideas?

 

 

See if it works if you connect the MK2 and then run AS7.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

 

Apparently, an uninstall, reboot, reinstall, reboot fixed the problem.

Now to learn how to use it.

Joe

Pages