Atmel Studio 7.0.1416/7.0.1417

Go To Last Post
98 posts / 0 new

Pages

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

meolsen wrote:

Over-active antivirus?

 

Good point, unfortunately not. During my problem analysis I disabled/closed all unnecessary windows processes. The Task-Manager doesn't give me helpful hints.

 

Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Sorry to be a pain, but where has Percepio Trace gone?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We've had to remove it since our redistribution license expired.

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Does it mean that it is removed from the Extensions as well? Can I revert the installation to a previous version to have it? Or will it disappear forever from the Extensions section? Is there a way to install it separately? Or will there be a similar feature installed?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

We have removed it from the studio installation due to the license. However, if Percepio wants to make it available in the gallery is up to them. I don't know if they want to do that (I haven't had the chance to talk to them about this yet). 

 

I'm sure that if you ask them you'll at least get an answer wink

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Are you aware that the Atmel Studio Webpage still shows 1188 as the latest. Just downloaded the 1188 full installer and the first question was: "There is a newer version ..." ... sigh. Also the release notes are for 1188. The ones you posted here are newer.

 

@meolsen: You're doing a great job, thanks :-)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes, we know...

Note that when you download 1188, you don't have to check the "download newest" (if that was the question).

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am not privy to the contractual agreements between Atmel and Percepio. My understanding based on your statements is that Percepio Trace was removed from the Gallery by Atmel because of the agreement's expiry, but Percepio might not know about it yet?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

the trace plugin was never on the gallery....

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Oh, so it was part of the install? so the previous versions of Atmel would still have it?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Jupp :) 

 

(there's also ways of moving it between versions, but I think I'm passing my usual grey-zone of operation if I divulge too much smiley )

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

kawosch wrote:

Hi,

 

I'm running the 1417 under Windows 7. Installation worked, it compiles, but my GUI stucks about every 5 seconds for about 1-2 seconds. This is very annoying, a continuous workflow is nearly impossible (the complete Atmel Studio is affected). Did anyone else encountered this problem so far? The last Atmel Studio (1188 for me) worked fine.

 

Regards

 

After a complete reinstallation of Atmel Studio .1417 (by as-installer-7.0.1417-web.exe) everything works fine, last time I updated from .1188. I know that Atmel Studio is based on VS 2015, but my web search showed me, that some VS 2017 users have exactly the same problem. (link1 link2)

 

Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Where there's a will there's a way. I had the will, so I found the way.

 

Nonetheless, the release notes for the latest version should specify the disappearance of Percepio Trace.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I just upgraded to the new version of Studio 7 7.0.1417. I'm using Windows 10. Now I can not see any of my programming tools.

The Device Programming screen shows: "There are no Available tools"

I also get an error saying "The back end process exited with code -1073740791"

What is going on?. Should I try to go back to my previous version. I'm using Windows 10.

Arturo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Is the new version still unofficial? I cannot find it on http://www.atmel.com/tools/atmel..., there is 7.0.1188. I can't find release notes for 7.0.1417 as well.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

That's right. However, when I tried to install 7.0.0.188 it says there is a later version and asks if you would like to install the newest version. I clicked yes and I got 7.0.1417.

Arturo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

7.0.1417 is official, it's just that updating the web site is a task that (obviously) takes some time. Not everything is running smooth after the merger. 

 

@acab, try to delete the content in Atmel\Studio\7.0\atbackend\codeCache\ and start Studio again. If not even the simulator is showing in the tools list there is nothing wrong with your tools, it's the backend that is having issues.

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Thanks for your response. Unfortunately I got impatient and I decided to go back and install the old version I had which was working mostly. But It would crash with an error of "AVR8 Device Support". Therefore, I tried to re-install 7.0.1417 but I got the same error.
When I checked the Atmel site I noticed that the latest version recommended is 7.0.1188. So I donwloaded it and tried to install with the same result plus more errors listed. It also shows some links on how to troubleshoot. However when I click them I get sent to a web page that is not working.

I submitted a support case to Microchip but no answer yet.

I noticed Atmel studio still shows up as an installed. I tried to uninstall but that only restarts the installation and I get the same error again:


So to summarize my problem is that I don't have Atmel Studio anymore and any attempt to install it fail.

How can I get Atmel Studio installed again?

Arturo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

FYI!

It seems my problem was a corrupted registry. Tried to Fix it with Microsoft Fix-It but didn't work. Finally I used Revo Uninstaller and that worked. Great program!.

I have installed version 7.0.1188. I still have to properly fix everything but I'm hopeful.

Thanks everybody for listening to my sorrow.

Arturo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

acab wrote:
When I checked the Atmel site I noticed that the latest version recommended is 7.0.1188.
Recently updated :

http://www.microchip.com/development-tools/atmel-studio-7

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yep... website says 1417.

Ross McKenzie ValuSoft Melbourne Australia

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

What's the "MPLAB" component installed when this version is installed?

 

Should I be worried we will eventually be forced to use that inferior IDE?

Last Edited: Tue. Apr 4, 2017 - 04:15 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

meolsen wrote:

We are working on updating the website. Getting there soon wink

 

Seriously? More than a month later and its still not updated!!!  How hard is it to update a link?

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

My "soon" and yours are probably different. Why shouldn't theirs also be different. cheeky

Ross McKenzie ValuSoft Melbourne Australia

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

What are you talking about... It's on the site...

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Morten he is talking about the Atmel site link where people would normally go for Atmel stuff, it is still 1188

 

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

But, Atmel didn't make 7.0.1417... :-)

(I'll ask the web guys to link over to the Microchip site...)

:: Morten

 

(yes, I work for Atmel, yes, I do this in my spare time, now stop sending PMs)

Last Edited: Fri. Apr 21, 2017 - 09:32 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Oh dear, things are starting to get "very interesting but stupid"...you may be to young to remember Laugh In.wink

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,

I'm using win10 creators update (attached file), Atmel studio 7 build 1417, Atmega324P MCU and JTAGICE3/Atmel ICE. I can use JTAGICE3 or Atmel ICE to flash the code to board successfully. But can not debugging due to "Debugger command Prog Mode Leave failed" error, then the FUSES were reset (JTAGEN changed from checked to unchecked).

Do you have any idea to resolve this issue? Thank you.

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hello,

I tried to update to 7.0.1417 on Win 7 but it doesn't work. AS installer says that I have to update Windows KB2999226 (essential) and KB2670838 and KB2978092 (optional), but all are installed!

I tried to deinstall the 3 updates and reinstall using Windows Update - no success. AS installer doesn't finish the installation because of the missing updates.

What's going wrong and how can I install 1417?

Hans

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

It’s always looking for IronPython v2.7.0.4

 

I had the latest IronPython installed 2.7.5, that didn’t work.

I reinstalled v2.7.4 and that didn’t work.

I can find a specific version 2.7.0.4

 

Thanks

Joe

 

 

 

If I try to create an Arduino project I get

 

If I click New Example Project I immediately get this

Joe

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

 

i installed AS 7.0.1417 on a Windows 10 64bit OS.

I have a AVR ISP MK2 Programmer.

 

In AS the Tools list stay empty, no Programmer, no Simulator.

Target is a ATtiny2313A.

 

The USB Device seems ok, and the programmer work with AVRDUDE.

 

Any Ideas?

 

Attachment(s): 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

lordraven wrote:

 

I have a AVR ISP MK2 Programmer.

..

In AS the Tools list stay empty, no Programmer, no Simulator.

Target is a ATtiny2313A.

..

Any Ideas?

 

 

See if it works if you connect the MK2 and then run AS7.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

 

Apparently, an uninstall, reboot, reinstall, reboot fixed the problem.

Now to learn how to use it.

Joe

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I have an error when i want to install the last version of AVR studio on windows 10

I need help, please smiley

lolo

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

The error message talks about an earlier version of "Microsoft Redistributable 2010" being present and that it is a "blocker" for installing Atmel Studio.

 

Are you sure about that youre trying to install "the latest version"? You're talking about "AVR Studio" but it's been caölled "Atmel Studio" for many years now. Also, I can (faintly) read in your screen shot that it tries to install "Microsoft C++ 2010 x86 Redistributable Setup". I do not think (but am not 100% sure) that it is a part of the latest Atmel Studio install.

 

As far as sI know Atmel Studio 7 is based on newer components than that from Microsoft.

 

Can you tell us what version of Studio you're trying to install? I.e. give us the version number. Also tell us where/how you got it.

 

BTW, your screenshot is ridiculously small and very hard to read. Whenever possible, it is much better to copy error messages as text and paste them in a post here. Or possibly do a decent screenshot and copy messages as text and post both.

"He used to carry his guitar in a gunny sack, or sit beneath the tree by the railroad track. Oh the engineers would see him sitting in the shade, Strumming with the rhythm that the drivers made. People passing by, they would stop and say, "Oh, my, what that little country boy could play!" [Chuck Berry]

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

Last Edited: Sun. Jul 2, 2017 - 04:51 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Hi,

Thanks for your response.

The version that i try to install is: 7.0.1417

 

my screenshot in text mode

"

OS Version = 6.2.9200, Platform 2
OS Description = Future OS - x64

CommandLine = d:\ac8c7fbe6640ed3b23c420963d\Setup.exe /q /norestart /log "C:\Users\cdt\AppData\Local\Temp\AtmelStudio_7.0.1417\\AS_20170702162238_0_VCRedistD10x86.log"
TimeZone = Paris, Madrid (heure d’été)
Initial LCID = 1036

Using Simultaneous Download and Install mechanism

Operation: Installing

Package Name = Microsoft Visual C++ 2010 x86 Redistributable Setup
Package Version = 10.0.30319

User Experience Data Collection Policy: UserControlled

Logging all the global blocks

 

Installation Blockers:

  1. Une version plus récente de Microsoft Visual C++ 2010 Redistributable a été détectée sur cet ordinateur.

 

Final Result: Installation failed with error code: (0x000013EC), "A StopBlock was hit or a System Requirement was not met." (Elapsed time: 0 00:00:00).

 

 

In fact: i have on my computer the version Microsoft Visual C++ 2015

 

Thank in advance

Laurent

lolo

Last Edited: Sun. Jul 2, 2017 - 05:02 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

lolo_albert@hot... wrote:
OS Version = 6.2.9200, Platform 2
OS Description = Future OS - x64
Is it Windows 8?  (via winver)

IIRC, Microsoft has ceased maintenance of Windows 8.

If it's Windows Server 2012 then that is maintained.

 

Microsoft

Microsoft

MSDN

Operating System Version

https://msdn.microsoft.com/en-us/library/windows/desktop/ms724832(v=vs.85).aspx

via https://superuser.com/questions/680825/am-i-running-windows-8-or-8-1#680874

Microsoft

Microsoft

Windows Server 2012 update history

https://support.microsoft.com/en-us/help/4009471

 

"Dare to be naïve." - Buckminster Fuller

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

OK. My French is a bit rusty, haven't spoken or written in it for 40+ years, so had to look up "récente" , and of course it's the same as the English "recent".

 

So, it looks like the Visual C++ 2015 has installed a newer version of the "redistributable" than the one coming with Atmel Studio.

 

I'm sorry, but I don't know what to do about this. One interesting StackExchange thread found while searching: https://stackoverflow.com/questi... . PErhaps there's something in that to help you?

"He used to carry his guitar in a gunny sack, or sit beneath the tree by the railroad track. Oh the engineers would see him sitting in the shade, Strumming with the rhythm that the drivers made. People passing by, they would stop and say, "Oh, my, what that little country boy could play!" [Chuck Berry]

 

"Some questions have no answers."[C Baird] "There comes a point where the spoon-feeding has to stop and the independent thinking has to start." [C Lawson] "There are always ways to disagree, without being disagreeable."[E Weddington] "Words represent concepts. Use the wrong words, communicate the wrong concept." [J Morin] "Persistence only goes so far if you set yourself up for failure." [Kartman]

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Could anyone share the note "How to downgrade to use older Jungo drivers." referenced in the release notes for 1417?

The Server behind the embedded link http://atmel.force.com/support/articles/en_US/FAQ/Downgrading-tools-to-use-older-Jungo-driver seem to be down and Atmel sales support is not answering my mail...

 

Thanks

Holger

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 1

Microchip support helped me. The support articles have been migrated to the microchip site:

https://microchip.secure.force.com/microchipknowledge/articles/en_US/FAQ/Downgrading-tools-to-use-older-Jungo-driver

 

Maybe they should put this info into the old database offline-message instead of the useless standard message i've got....

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

meolsen wrote:
Hopefully this will resolve the ongoing issues with Windows 10 that are piling up.
Is it possible for Atmel Studio to eventually be in Microsoft Store?

Reason : Windows 10 S

Am uncertain this is possible because Microsoft Visual Studio is not in Microsoft Store though Atmel Studio having Visual Studio Isolated Shell may make this a possibility.

Windows 10 S is likely to be popular in the US for primary, secondary, and post-secondary education and for libraries.

Locally, I doubt Arduino is in secondary schools; any primary and secondary educational use of Arduino is at one library with one professor from the engineering college.

With a reasonable drive, or a few/several mass transit rides, one can be at one library that has a makerspace.

The upgrade to Windows 10 Pro from S has a price of 49USD for a low price notebook PC (zero for more expensive PC with the zero price upgrade ending 2018-Mar-31)

 


Computerworld

How Windows 10 S is different from the Windows 10 you know

Windows 10 S isn't just for education; Microsoft hopes the new Windows edition will find its way into homes and enterprises, too. But beneath the familiar user interface are some significant differences.

by

Computerworld | Sep 25, 2017

https://www.computerworld.com/article/3227066/microsoft-windows/how-windows-10-s-is-different-from-the-windows-10-you-know.html

...

This is a full version of Windows with some limitations, one that’s designed to start up quickly, have long battery life, and keep working properly month after month after month, without resets or support calls.

...

Another is that schools are usually short on IT resources, so they’re looking for simpler management options that rely on the cloud.

...

 

A pristine PC

...

More significantly, this is a Windows that restricts which applications you can run (they have to come from the Windows Store) and ...

...

That [Azure Active Directory] removes Group Policy, a feature that gives IT admins control but also slows systems down and makes Windows fragile.

...

Instead of Group Policy,  it’s managed the way smartphones and tablets are, using MDM tools and cloud identities.

...

... and to install apps – either online or via a USB stick that teachers or admins plug into Windows 10 S devices.

...

Because Windows 10 S only runs software from the Windows Store, all the apps use a virtualized registry, so one app can’t affect the settings another app uses.

 

Windows Store restrictions

...

You can install desktop applications on Windows 10 S, but only if they’ve been sandboxed by Microsoft’s Desktop Bridge tool and come through the Windows Store.

...

Other software publishers using the Desktop Bridge tool to deliver software include ...

...

 

How to get Windows 10 S

...

... Windows 10 S ISO is available on the Microsoft Developer Network so schools can put it on their existing hardware and IT departments can test it.

...

(other than MSDN, it's on specific new OEM PCs)

 

How to get off of Windows 10 S

...

Schools can switch to Windows 10 Pro Edu at any time and at no cost.

...

via https://www.askwoody.com/2017/curious-about-windows-10-s-mary-branscombe-has-an-in-depth-report/

 

Microsoft

Microsoft

Windows

Desktop Bridge

https://developer.microsoft.com/en-us/windows/bridges/desktop

 

Edit : third URL

 

"Dare to be naïve." - Buckminster Fuller

Last Edited: Mon. Oct 2, 2017 - 06:06 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

scratch

Klaus

Last Edited: Tue. Oct 10, 2017 - 03:12 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Reason : Windows 10 S

Can the next major version of Atmel Studio run on Windows 10 S?

Reason: Windows 10 Enterprise in S Mode

 

Computerworld

Enterprises to get locked-down Windows 10 in six months

‘Windows 10 Enterprise in S Mode,’ a locked-down version of Windows 10 S, will be available from Microsoft in April or May 2018.

by Senior Reporter, Computerworld | Oct 13, 2017

https://www.computerworld.com/article/3232749/microsoft-windows/enterprises-to-get-locked-down-windows-10-in-six-months.html

...

"It's about having the best of Windows 10 S and the best of Windows 10 Enterprise in just one subscription package." - Augusto Valdez, a director of product marketing in the Windows group

...

... Microsoft 365 F1 (M365 F1) [10USD/mon] ...

...

 

Like Windows 10 S, only more

...

... only apps from the just-renamed Microsoft Store can be installed under the OS and will run on it.

...

... simpler management for IT.

...

 

Only on 10 S devices

...

During Ignite [Microsoft technology conference, Orlando, 2017-Oct], several OEMs, including HP and Lenovo, trotted out new notebooks, some starting as low as $275, that came with Windows 10 S.

...

 

Enter Microsoft 365 F1

...

M365 F1 consists of three parts: Office 365, Windows 10 and Enterprise Mobility + Security (EMS), a collection of device- and user-management services and tools.

...

upgrade : Windows 10 Pro to Enterpise, upgrade : Windows 10 S to Enterprise in S Mode

...

 

What's next?

...

[desktop PC]

...

In that scenario, only the latter [notebook PC with Windows 10 Enterprise in S Mode] would leave the multi-layered defenses of the company's network.

via https://askwoody.com/2017/where-windows-for-businesses-is-headed-details-about-win10-enterprise-in-s-mode/

 

Edit: typo

 

"Dare to be naïve." - Buckminster Fuller

Last Edited: Fri. Oct 13, 2017 - 10:14 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Why does the "Update pack, The project is referring to a pack that is not installed" happen?  Are these things that did not get downloaded installed with the main program install?

 

It is cool that the int24 has been added.  I sure would love to see double floating point too!

Last Edited: Fri. Nov 3, 2017 - 03:06 AM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

@Morten can (and will) probably correct me if I'm wrong, but packs installed when installing Atmel Studio will be updated/replaced with newer versions when you install a new Atmel Studio version. Packs you have manually installed will be left untouched. Your project was created before you updated Studio, and the Studio update upgraded the part pack.

 

All part packs are available at packs.download.atmel.com, so you can get any version you want.

Pages