the most reliable version of atmel/avr studio?

Go To Last Post
15 posts / 0 new
Author
Message
#1
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

First I downloaded tmel studio 6.2, I had to stop using it because of an irritating bug which means I can't program a chip more than once without rebooting the program. Then I tried AVR studio 4, where there is a bug which means I have to manually enter the path to avr-gcc and the make file for every new project (and some other suspicious behaviour I am attributing to bugs...) 

Is there a version of atmel/avr studio which doesn't have such conspicuous bugs? Are there other programs people use to program avrs - I can't believe these can be programs can be used by anyone professionally? Why is it so difficult for atmel to make their proprietary software work properly?    

rant over...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I use 6.2 on a Win8 laptop - use it a lot at times. Never had the problems you describe. Nor, have I heard others with such problems.

 

Jim

Jim Wagner Oregon Research Electronics, Consulting Div. Tangent, OR, USA http://www.orelectronics.net

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

well, I envy you

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

well, I envy you

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I use Atmel Studio 6.2 also and have had none of the problems you describe.  I've had other problems but not any major!

Last Edited: Mon. Jan 26, 2015 - 06:44 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

i posted about it on this thread, seems that there are other people who experience the same problem with atmel studio 6.2, I found a thread about the problem with avr studio 4 too...

 

http://www.avrfreaks.net/forum/a...

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

In both of your threads you have not said what version of Windows you are running or if you are running Windows in a VM.

 

This is a community supported forum so you may not get your problem resolved here.  Have you filed a support incident with Atmel directly?

 

Now you have two threads discussing the same issue.  That is called cross posting and is a practice that is frowned upon.

 

 

"When you arise in the morning think of what a privilege it is to be alive: to breathe, to think, to enjoy, to love." - Marcus Aurelius               

Last Edited: Mon. Jan 26, 2015 - 07:23 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

I am currently running windows 7 off bootcamp, although have experienced both problems identically with my work computer which is a windows 7 pc

I am only seeking to find which version of atmel/avr studio might provide me with the best chance of trouble free operation, I often read threads where people cite "another reason not to upgrade to version x" etc and thought maybe there are well regarded versions out there. I am not directly seeking to remedy the problems unless I absolutely can find no version of atmel studio which will work properly, although if it comes to that i will indeed file a report with atmel directly. 

Last Edited: Mon. Jan 26, 2015 - 07:35 PM
  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

In answer to your question, I am using Atmel Studio 6.2sp1 on Windows 8.1.  There are some issues with the USB drivers that are being addressed by Atmel.  Other than that the product is quite stable.

 

I recommend that you file a support incident with Atmel. 

"When you arise in the morning think of what a privilege it is to be alive: to breathe, to think, to enjoy, to love." - Marcus Aurelius               

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

Yes there certainly are "some issues". i will file a report, I suppose in the meantime i'll have a go with 6.1

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

 

Be aware too of a recent option

Microsoft Visual Studio Community - free. Plus the free VisualMicro plug-in.

This is a big deal.

 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

studio 4, where there is a bug which means I have to manually enter the path to avr-gcc

Is this with AS4.19? No such problem with AS4.18 Sp3.

John Samperi

Ampertronics Pty. Ltd.

www.ampertronics.com.au

* Electronic Design * Custom Products * Contract Assembly

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

 

Be aware too of a recent option

Microsoft Visual Studio Community - free. Plus the free VisualMicro plug-in.

what is this option? Can you explain?

Is this with AS4.19? No such problem with AS4.18 Sp3.

yes, it is with AS4.19, maybe I could try 4.18... 

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

There are good commercial options available.  I'll leave it at that.

 

Jim

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0

At the moment I use 4.18 allmost every day and it seems stable. (4.19 is bad).

 

my system say this :

AVR Studio        4.18.684  
GUI Version        4, 18, 0, 670
AVR Simulator        1, 0, 2, 1
ATMEGA324P        51

Operating System
Major            6
Minor            1
PlatformID        2
Build            7601
Service Pack 1

Plugins:

AvrPluginAvrAsmObject    1, 0, 0, 48
AvrPluginavrgccplugin    1, 0, 0, 11
Stk500Dll            1, 0, 1, 13

 

If it's any help.

 

And I use this compiler (hand added ): C:\WinAVR-20100110\bin\avr-gcc.exe

and with this make :C:\WinAVR-20100110\utils\bin\make.exe

 

I use win 7